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PURPOSE
The main purpose of this document is to outline the different 
methods available to MYER Marketplace Sellers to integrate into 
the MYER eco-system via the Marketplacer platform, and how 
each format works.

MYER utilizes Marketplacer as an EDI platform to connect 
Marketplace Brands to its platform.

Table of Contents
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There are 3 ways to integrate your source platform (Shopify, BigCommerce, Wix, etc) 
with Marketplacer, to integrate into MYER -

API (M-Connect): This is the preferred and most efficient method of integration where 
we input your API keys into Marketplacer. Marketplacer will then automatically begin to 
import listings from your platform, for the MYER team to begin the integration process

MANUAL: This method requires you to manually create products and update stock, 
price, etc regularly via an excel sheet import

CUSTOM API: There is also a provision in Marketplacer to connect via a custom API set-
up to create & manage products, fulfil orders, etc

Integration Methods
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Marketplacer uses M-Connect as its software to 
enable retailers to sync products, inventory, and 
order information between Marketplacer and 
third-party platforms such as Shopify, 
BigCommerce, Maropost, Magento, etc

Using the API method to integrate into 
Marketplacer is simple and efficient. We will 
require you to provide us with your API Keys, 
Access Token and Store URL.

Before you provide the API Keys, ensure you tick 
the required permission settings in the Admin 
API Access Scopes screen. The screenshot on the 
right is the Shopify ‘permission screen’. You will 
find more info on Shopify in the next few slides

1. API [M-Connect]
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API [M-Connect]
Shopify Integration into Marketplacer
Shopify integration for sellers uses Shopify's APIs to access the Shopify store's data. To configure this connection in 
Shopify, create a custom app through the Shopify Admin dashboard if you don’t have one already.

The following instructions focus on the steps needed for the integration to work with Marketplacer. 

Detailed instructions for adding a custom app are available in the Shopify help center.

1. In the Shopify Admin Dashboard, select Settings in the left-hand menu. Store details displays.

2. Select Apps and sales channels in the left-hand menu. Apps and sales channels displays.

3. Select Develop apps. App development displays.

4. Select Create an app. If this is your first custom app, a dialog displays prompting you to select Allow custom 

app development. The Create an app dialog displays.

5. Enter the App name and the App developer. We recommend that you use the store owner as the App developer.

6. Select Create app. App development displays, with the application name.

https://help.shopify.com/en/manual/apps/custom-apps
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API [M-Connect]
Shopify Integration into Marketplacer

7. Select Configure Admin API scopes.

8. The Admin API access scopes page displays a list of API scopes, in alphabetical order. To enable the integration:

• For Inventory select write_inventory and read_inventory.

• For Orders, select write_orders and read_orders.

• For Product Listings select read_product_listings.

• For Products, select read_products.

• For Locations, select read_locations.
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API [M-Connect]
Shopify Integration into Marketplacer

9. To confirm these are set correctly, select Selected. This filters the list to show only those items that are selected.

10. Select Save. App development displays, with the Install app button enabled.

11. Select Install app. A confirmation dialog displays.

12. Select Install. The API Credentials display
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API [M-Connect]
Shopify Integration into Marketplacer

13. Select Reveal token once

14. Record the API access tokens required by Marketplacer and send it to the MYER team:
• Admin API access token 
• API key
• Store URL: The Shopify Store URL is the URL on the back-end of your Shopify Store. Ensure that you use the 

Shopify Store Domain (e.g your-store-name.myshopify.com) rather than your public domain (e.g
www. your-store-name.com).

Here’s an example of what this information looks like:

API Key: ae17c9bb6f8586a3175511111111111

Admin API Access Token: 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

Store URL: https://mystore.myshopify.com/ (ensure you provide us with the Store URL and not the Store Admin URL)

You may find this video link helpful for more information on how to access the API details - https://www.youtube.com/watch?v=Tn0DzYnRPVQ

https://www.youtube.com/watch?v=Tn0DzYnRPVQ
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API [M-Connect]
Helpful links for integrating other common platforms into Marketplacer

https://support.marketplacer.com/hc/en-us/articles/360034856532-Maropost-Commerce-Cloud-Connection-Setup

https://support.marketplacer.com/hc/en-us/articles/360035231951-Connect-and-set-up-WooCommerce-integration

https://support.marketplacer.com/hc/en-us/articles/360039602272-BigCommerce-connection-setup

https://support.marketplacer.com/hc/en-us/articles/360034856532-Maropost-Commerce-Cloud-Connection-Setup
https://support.marketplacer.com/hc/en-us/articles/360035231951-Connect-and-set-up-WooCommerce-integration
https://support.marketplacer.com/hc/en-us/articles/360039602272-BigCommerce-connection-setup
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▪ The MYER Integration & Onboarding team (I&O Team) will input the API Keys into Marketplacer to 
connect to your store. This will then trigger an import of all your listings from your source 
platform into Marketplacer

▪ I&O Team will map all your products into the relevant MYER product categories, ensuring they 
are ready to trade on MYER.com.au

▪ Supplier is then required to provide a list of all products they wish to register and trade on 
MYER.com.au via an IRIS Template. Please note that even though all the products get imported 
into Marketplacer, you will still be required to give us a list of the items from this list that you wish 
to trade on MYER 

▪ The I&O Team will help you through the steps and request for any additional information that is 
required

API [M-Connect]
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API [M-Connect]
Where can I view my products within Marketplacer?

Once the sync is successful between your platform and Marketplacer, you can view your products in 2 locations:

1. Log in to Marketplacer>Manage Products 2. Log in to Marketplacer>Extensions>
M Connect>Go to M Connect

More info on Point 2 in the next page
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API [M-Connect]

Total number of products fetched by 
Marketplacer when sync was enabled

Any import error will show here 
with description of what the error 
relates to (eg – Taxonomy 
missing, Barcode missing, etc)
Click on ‘Details’ for more info. 
Click into the product to fix any 
errors
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API [M-Connect]
What are the most common import errors in Marketplacer?

1. INVALID BARCODES – All products listed should have a valid 13-digit GS1 compliant barcode. The barcode in 
Marketplacer and Retek (Myer system) should match for a product to successfully flow through to other 
systems within Myer including the website. If you’re using a UPC barcode, a leading ‘0’ should be manually 
added since they will usually be a 12-digit number

13-digit barcode

Leading ‘0’ to the UPC 
barcode
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API [M-Connect]
What are the most common import errors in Marketplacer?

2. ‘NOT ACTIVE’ STATUS – This product state relates to products that have a ‘False’ status in the ‘Status Active’ 
column. This generally occurs when the products are not listed as ‘Active’ in the Seller’s platform. (for eg – a 
product marked as ‘inactive’ in Shopify’ will show as ‘False’ status in Marketplacer).
Products that are in ‘False’ status will not flow through to Myer systems Status Active is False indicating that the 

product is not set to Active in the 
Supplier’s systems. Once the items are 
set to ‘Active’ at the Supplier end, this 

status will change to ‘True’ when 
Marketplacer pulls in an API  update
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API [M-Connect]
What are the most common import errors in Marketplacer?

3. SALE PRICE > BASE PRICE – Ensure the Sale Price of a product is lower than the Base Price. If not, Marketplacer 
will show an import error
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API [M-Connect]
Important Catalog Listing Rules

1. VARIANTS
When listing products, ensure colour variants are listed as separate/individual products. Myer systems only 
support size variants. Hence, similar products in different colour variations need to be listed separately 

The products listed here contain 2 
colour variants – Black & Olive. This is 
incorrect. Both colour variants need to 
be listed as separate adverts/listings 

within Marketplacer
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API [M-Connect]
If a product has size variants, these need to listed as below under 1 advert ID
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API [M-Connect]
2. GENERAL GUIDELINES

• Products should have up to 3 images. Ensure images are not added at variant level

• All products (including variants) should have unique barcodes

• Product Title should be of less than or equal to 100 characters

• Product description should be a minimum of 150 characters and a maximum of 5000 characters. Exceeding this limit will 
restrict the workflow into MYER systems

• Products should include a standard price

• Category & Brand name should be filled in

• Add in the size and colour for each Product if applicable for your category (View Product > Variants > Edit > Select       
size/colour from dropdown and Save)
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API [M-Connect]

• Go to Products > Mapping

How to update attributes – Brand / Category / Size / Colour & Barcodes in Bulk

• Depending on what you’re looking to update, select from the Tabs on top – Brand, Category, Option Type and Option Value. 
• Brand – Search your Brand by clicking on Edit and hit Confirm after selecting to save the changes

• Category – Under Category section > Check a product that is in line before selecting the category by clicking on the 

product count. Search your category by clicking on Edit and hit Confirm after selection to save the changes

• Size/Colour - Under Option Type and Values section > Check a product that is in line before selecting the size/ colour 

by clicking on the product count. Search your size/colour by clicking on Edit and hit Confirm after selection to save 

the changes.
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API [M-Connect]

• Go to Products > Bulk Upload Products > Generate > Select All > Confirm Selection > Download

How to update attributes – Barcodes in Bulk

• Open the sheet you just exported. Update the 
Barcodes in Column ‘AO’. If the Barcode is an 
UPC barcode, convert the input format to text 
and add a leading ‘0’ to the number. 

• Once the Barcodes are filled in the sheet, 
you can Save and upload the file back into 
Marketplacer on the same page



PAGE 21NAME OF PRESENTATION NAME OF SECTION PAGE 21

2. MANUAL INTEGRATION
Manual integration into Marketplacer requires Sellers to manually create/upload products and 
manage pricing, stock, etc via a spreadsheet regularly. This approach provides Suppliers with a 
bulk option that is less manual than adding products one-by-one but does not require 
automation (M-Connect).
Suppliers are not locked into an integrated approach; they may choose to try the manual method 
and then switch to spreadsheet uploads or M-Connect. This section explains how you can 
manually add products into Marketplacer. 

Check that you’re using the latest version of the Marketplacer Seller portal
Two versions of the seller portal exist, differing in appearance and menu structure. The icon in the 
top right-hand corner of your seller portal will tell you which version you’re on. Always ensure 
you’re using Seller portal 2.0: 
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MANUAL INTEGRATION
HOW TO ADD INDIVIDUAL PRODUCTS

1. Go to the Products > Manage Products
2. In the Manage Products page, click Add New Product
3. Complete the Product Information and click Next
4. Complete the Product Details tab and click Next
5. Complete the Pricing tab and click Next
6. You can add images, videos, and PDFs in the Media tab (remember to provide a custom thumbnail 

image when adding a custom video URL)
7. Click Next
8. In the Variants tab, click Create New Variant. The Create New Variant window opens
9. Complete all the variant details and select Save Variant
10. To add more variants, repeat from Step 7
11. Once you are ready to add the product, click Submit

For a video reference of the steps, check https://youtu.be/nEdHOsMvOWw

https://youtu.be/nEdHOsMvOWw
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MANUAL INTEGRATION
HOW TO ADD PRODUCTS IN BULK

You can bulk import products into Marketplacer through the Seller Portal if you have many products to 
add or if you are manually adding variants to existing ones.

1. Log in to the Seller Portal
2. Navigate to Products > Bulk Products Upload
3. In the Download a spreadsheet section, select the file format between XLSX or CSV

Using CSV may corrupt special characters in the title, description, or other details. We 
recommend using XLSX
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MANUAL INTEGRATION
4. Update the spreadsheet with the products you want to add. If you are unfamiliar with the bulk 

upload spreadsheet, see Understanding Bulk Upload Product Spreadsheet
5. Go back to the Bulk Upload Products page in the Seller Portal
6. Click Upload spreadsheet and select the file you updated. Ensure your entries align with the 

product structure (taxonomy) set by MYER
7. Choose whether to override existing product data:

▪ If you are adding new products, do not select the checkbox that removes existing products and 
variants

▪ To manage all your products and replace all data, select the option to remove all existing 
product and variant data

8. Click Upload
9. To monitor the status and check if there are import error, scroll down to the Recent Import History

section
10. Note: If errors occur, you can fix them directly in the product list or edit the spreadsheet and re-

upload

https://support.marketplacer.com/hc/en-us/articles/8839161297037-About-the-bulk-product-upload-spreadsheet
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MANUAL INTEGRATION
HOW TO ADD/EDIT PRODUCTS IN BULK

For adding or making changes to multiple products in Marketplacer, you can edit your full product list 
in a spreadsheet and then upload the file to make changes. This is more efficient than editing products 
manually.

You might do this, for example, to rename or update multiple product descriptions or details.

Step 1 : Download and edit existing product list

1. Log in to the Seller Portal
2. Navigate to Products > Bulk Products Upload
3. In Step 1, select the preferred file format: CSV or 

Excel
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4.  Under the label Existing ads, select Download. This downloads a list of your current products.
5.  Open the file in a spreadsheet program. If you are not familiar with the spreadsheet layout, see 

Understanding Bulk Upload Product Spreadsheet
6. Edit the products listed in the spreadsheet

You will need to provide the following information in the document for upload:
• Brand
• Variants (i.e Size options)
• Stock Level
• Barcode (13-digit GS1 barcode)
• SKU 
• Title Description (name of the advert/product - (less than or equal to 100 characters)
• Main Description (minimum 15 characters and a maximum of 5000 characters. Exceeding this limit will restrict the flow into MYER 

systems)
• Price
• Images (Myer can accept up to 7 but no less than 3)
• Taxonomy (categorisation)

Adding categories – MYER will provide you with a taxonomy tree that outlines applicable categories and any prototypes and subtypes that are 
required per category. When filling out the Categories in the advert file, it is important to make sure it is like-for-like i.e.
all lower-case letters

7.  When you have finished, save the file ready for upload

If you’d like to know what each of the fields in the template means, check the next 2 slides, before moving on to Step 2 – Importing the 
sheet back into Marketplacer
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MANUAL INTEGRATION

https://support.marketplacer.com/hc/en-us/articles/8839161297037-About-the-bulk-product-upload-spreadsheet
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MANUAL INTEGRATION
UNDERSTANDING WHAT EACH COLUMN MEANS IN THE TEMPLATE

▪ Advert ID: Marketplacer Advert ID. You will not need to fill this column in when uploading new adverts – it will auto publish
▪ External ID: Connection ID from Supplier backend - only applicable to M-Connected Suppliers
▪ Publish Advert [Yes/No]: Yes
▪ New or Used: New
▪ Gender [m/f]: Set whether the product is for males, females or unisex
▪ Category 1/2/3: This is the Myer categories and subcategories – taxonomy - you will need to ensure that you are mapping the products into
▪ the correct categories
▪ Brand: The brand who made this product - any difference in spelling to what is entered by Myer will cause the upload to fail
▪ Variant Option Name: This is the variant option name i.e. Colour/Size
▪ Variant Option Value: This is the variant option value i.e. Red/12
▪ Stock level: Update the stock level of all products
▪ Variant ID: For downloaded adverts; this is the ID associated with any advert variants (i.e. the same product in a different colour) - this does
▪ not need to be added for new adverts
▪ Variant External ID: Connection ID from Supplier backend - only applicable to M-Connected Suppliers
▪ Variant Price: The price of any variants, i.e. an Oak table may cost more than an iron table of the same design

*Please Note: If bulk updating advert prices, ensure both the base price and the variant price is updated
▪ Barcodes: GS1 13-digit Barcodes
▪ SKU: Advert SKU
▪ Variant Notes: Variant Notes assist when mapping products; an example of a variant note is ‘Colour: Red’ this will let you know what colour
▪ the variant item is, this auto populates when M-Connected
▪ Variant Shipping Width/ Length/ Depth: N/A
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MANUAL INTEGRATION
UNDERSTANDING WHAT EACH COLUMN MEANS IN THE TEMPLATE

▪ Title Description: Product title; limited to 160 characters in length
▪ Main Description: Product description
▪ Specifications: N/A
▪ Feature Option Type: N/A
▪ Feature Option Value: N/A
▪ Base Price: Product Base Price

*Please Note: If bulk updating advert prices, ensure both the base price and the variant price is updated
▪ Image 01 (Main): Set the main Product image

*Please note: images have to be uploaded as a URL link and cannot be a lifestyle shot
▪ Image 02-20: A seller can upload up to 20 images however, the minimum is 3 images and Myer will only accept and enrich the first 7

*Please note: images have to be uploaded as a URL link
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CREATING MULTIPLE VARIANTS UNDER ONE ADVERT ID
If a single product has multiple variants i.e. Size; you do not need to fill in the category lines for each variant of that product. Same goes 
for Title, Description and Image links. This distinguishes each individual product for the system when uploading so that you do not end up 
with a separate Advert for each variant.

Please Note that MYER does not allow for Colour Variants, only Size Variants

Common Errors:
▪ There are spaces, special characters or spelling mistakes in your CSV; this includes capitalisation of Category names, Option

Type/Value names, Brands etc. These must all be listed exactly as they appear in the site architecture i.e. The category is listed in the 
backend as "Beds" but on the spreadsheet the category is listed as "bed" this means an error will occur and the spelling on the 
spreadsheet will need to be amended to "Beds"

▪ The categories (Category 1/2/3) have not been mapped correctly, or in full
▪ The brand does not exist or needs to be created by the Myer I&O team
▪ Variants or features do not exist; for example, a seller could have the variant option value ‘lilac’ however the closest option value in the 

platform is purple.
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MANUAL INTEGRATION
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MANUAL INTEGRATION
Step 2 : Upload edited products to the seller portal

Before you upload, make sure columns are not hidden, and 
filters are off.

1. Go to Products > Bulk Products Upload
2. In the Step 2 section, select Choose File and select the spreadsheet

3. Decide if you want to override all your current product and variant data
4. If the spreadsheet contains only the products you are editing (not the full list of your products), DO NOT 

select the checkbox that removes all your existing adverts and variants
5. If all your products are listed in the spreadsheet and you want to replace all information about your 

products in the seller portal, select the option to remove all existing product and variant data
6. Select Upload ads to import the spreadsheet data. Depending on how many products you have added, the 

upload time can vary between a few minutes and about 30 mns for very large files
7. Check the Update Status list at the bottom of the screen to see when the upload is complete, and if errors 

were detected
8. If there were any errors, you can fix them individually in your product list or else edit the spreadsheet to fix 

them and upload the edited list
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3. CUSTOM API INTEGRATION
This type of integration allows you to build a custom API to connect your systems to Marketplacer. 
However, there is limited support provided from MYER and Marketplacer when building a custom 
integration. This build is usually completely executed by the Supplier.

The Custom API will facilitate product creation including updating product copy, attributes, images 
and pricing in Marketplacer.

Here are 2 useful links that will provide you with all the relevant information to be able to build a 
custom integration into Marketplacer:

Seller API - https://dev.marketplacer.com/docs/seller-api/

Webhooks - https://dev.marketplacer.com/docs/webhooks/

https://dev.marketplacer.com/docs/seller-api/
https://dev.marketplacer.com/docs/webhooks/
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CUSTOM API INTEGRATION
GENERATING AN API KEY

Sellers are responsible to generate their own API key within Marketplacer. You must generate an 
API key to use the API. Follow the below steps to generate a key –

1. Go to Extensions > API Access on the left-side menu. The API Access & Documentation page 
opens with a list of existing API keys.
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CUSTOM API INTEGRATION
2.  To create an API key, provide this information in the Create new API Key section:

• Description: Provide a unique description. The description must reflect the intended use of 
the API key.

• Organization: Enter the legal name of your organization.
3.  After you read and understand the API license, select the checkbox beside ‘I have read and 

understood the API License’.
4.  Click Create API Key. The API Key windows display showing the API key. You can only see this 

value once.
5.  Copy and paste the key to a safe place.
6.  Click Close

Note: You can no longer retrieve the key when you close this panel and browse away 
from this page. So make sure you copy and save this as you would a password!
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How orders and payments are transmitted to you

ORDERS
Marketplacer does not 
group orders by 
Customer’s email. This 
is because each line 
item needs to be split 
out into a separate 
Marketplacer Invoice 
Numbers (as a 
customer may have 
one Myer order but 
have items in their one 
basket from multiple 
Marketplace vendors)

Once orders are fulfilled, 
Supplier will require to 
update Marketplacer 
with the Carrier Name 
and Tracking Number for 
each order/invoice. 
If you’ve connected via 
API or built a custom 
integration into 
Marketplacer, this 
information will should 
flow through 
automatically to 
Marketplacer

Inputting a Carrier Name 
and Tracking number is 
the only way to ensure 
the order status is closed 
in the MYER system

PAYMENTS
The Supplier does not 
invoice Myer for orders.
MYER holds the transaction 
with the Customer and 
therefore Myer receives and 
holds the funds paid by the 
customer.
MYER remits the Supplier as 
per your contractual terms 
for all transactions 
captured within that 
payment period (payment 
being transaction value 
paid by the customer less 
Myer 20% commission)

RETURNS
Customers can return a 
product (in new, unused 
condition in original 
packaging) to one of our 
stores or utilising Myer’s 
Australia Post account 
within 30 days of purchase.
Myer will then onforward 
the returns back to your 
designated Australian 
warehouse. You will also be 
able to track these returns 
via our supplier returns 
portal.



PAGE 35NAME OF PRESENTATION NAME OF SECTION PAGE 35

Important MYER Contacts & Information for all your queries

• Queries regarding your Account or any Urgent issues – your Account Manager
• Queries regarding Integration and Onboarding into MYER systems – integration.onboarding@myer.com.au
• Queries regarding product enrichment including product copy and images – onlineenrichment@myer.com.au
• Queries regarding sales/returns reporting access - b2bsupplierportal@myer.com.au
• Queries regarding order enquiries (post purchase), refunds and base price changed -

dsvoperations@myer.com.au
• Queries regarding sale/promotional pricing via PEP - onlinepromotions@myer.com.au

SUPPLIER TOOLBOX - https://doc.pep.myer.com.au/
The Supplier Toolbox is a great online resource to learn about Enrichment processes including product copy and image 
guidelines, MYER processes, workflows, etc. Bookmark this page for quick access as it is regularly updated with 
everything you need to do know to help understand the MYER ways-of-working.

mailto:integration.onboarding@myer.com.au
mailto:onlineenrichment@myer.com.au
mailto:b2bsupplierportal@myer.com.au
mailto:dsvoperations@myer.com.au
mailto:onlinepromotions@myer.com.au
https://doc.pep.myer.com.au/
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